SuperMoto Junkie banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hey guys, I'm kinda stuck in understanding whats happening with my bike.
My 2011 Husqvana SM630 (which is only ~2000mi) is loosing coolant after good wheelie pulls. Just a couple of wheelies makes every hose connection literally bleed with coolant. The weird part of it comes when i keep both wheels on the ground while still riding it hard - everything is fine and I see no leaks.
Yeah, it is hot outside, but I believe this is not an issue with overheating.
I've disassembled the cooling system partially - checked the radiators, thermostat and hoses - they look in normal working condition.

Well, i guess this isnt a normal behavior and hoping to get some advice here on how to fix it.
._.
 

·
Registered
Joined
·
191 Posts
is the rad cap the correct lbs?
does the inner spring move freely?
what type of hose clamps do you have on it?
i replaced all my oe w/ worm gear. constant torque types are also good but the heat shrink are the best
 

·
Registered
Joined
·
1,805 Posts
Mine loses some out of the overflow bottle cap after a good hard run, no matter how much I've got in it, but it doesn't seem to be dropping any appreciable amount in the radiators... :headscrat

The bottle design is pretty crummy on the 610/630, thinking about finding a vertical-mount replacement with a better cap...
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
1.4 on a cap. Stock. Same as hoses.
Btw, I see trails of coolant peeping from the bottle cap, but no fluid in the bottle itself at all.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
omg, i'm loosing coolant, i'm loosin coolant, what could it be?! o_O


Okay, well, so i got the same curse as many new husky owners - alexon radiators. Right radiator developed a very sneaky leak that couldn't be found with compressed air in a bath - it dropped some coolant only when hot and after wheelie landings, wetting all my hoses and making me crazy.

I have this radiator trashed, but somewhat working. Original part costs ~200 bucks, and i'm surely not paying for same alexon quality crap.
Any ideas what to replace it with? ;/
 
1 - 5 of 5 Posts
Top