SuperMoto Junkie banner
1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
hi guys and gals, i have ccm 644 dualsport 2003

its great apart from high rev range...

when im out and about , and im in mid range the bike is great, when i give it a handfull, it lurks...

its at about 6500-7000rpm like when your overtaking someone, and you pull out it starts to seem like its running out of fuel but isnt???

ive had the carbs off and checked for air leaks, ive checked the needle settings, they are fine, the needles are at the lowest setting (tried all) so loads of fuel, the tps is in the middle, the mixture screws are 3 turns out but ive tried 2.5 and all the way in, it has no airfilter on it, (same with filter) it has a leo vince system exhaust.

none of the above makes a difference to this issue.

ive also checked the plugs and they are the right colour.

it also backfires alot, but the floats are not sticking or full of petrol.

the jet is 132.5 is this an issue do i need bigger ones, and why do all of the above, not make a difference running wise, as the mixture screws dont seem to matter, nor the tps...it just runs the same whatever the position/setting....its doing my head in...its the suzuki engine one.

there are no tears in the carb diaphrams, the jets are clean...

the bike is mint with 5k on the clock

aghhhhhhhhhhh.....crappy ccm's

any idea's

:rant:

 

·
Registered
Joined
·
1,639 Posts
One thing i dont see here is setting the float height. That is also critical for the main so maybe the float height is a little low. Im not familiar with the ccm but that would be my next step.
 
1 - 3 of 3 Posts
Top