SuperMoto Junkie banner

1 - 11 of 11 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter · #1 ·
Can someone post some pics of your PCV install on your 09 510 smr? Just got mine and plan to install it monday, just looking for some ideas.. Thanks :bannana:
 

·
Registered
Joined
·
185 Posts
Can someone post some pics of your PCV install on your 09 510 smr? Just got mine and plan to install it monday, just looking for some ideas.. Thanks :bannana:
I presume when you say you're looking for ideas, then you mean where to put it rather than the connection process:hmmm:
 

·
Registered
Joined
·
546 Posts
I just stuck mine under the battery strap. Seems okay and I see no reason to put it anywhere else. Do a search and you'll find a couple threads with pics of how other people have done it. Also, Dynojet has installation photos.
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #4 ·
Yeah just looking to see where some of you put the PCV box. I dont want to stick it to the insde of the rear side cover like they want. Im real picky and just like things neat and functional. I dont want it falling off or coming loose 10 miles down the road. No other replys so I guess ill come up with something. Thanks
 

·
Registered
Joined
·
546 Posts
Mine hasn't come loose even when casing jumps at the supermoto track. Also check CafeHusky for pics. At least one guy had a real nice install. I agree about improving upon the DJ install. One more ebbing, the TPS pickoff goes to the third wire from the end. DJ instructions haves the wrong wire color specified.
 

·
Registered
Joined
·
3,117 Posts
I put mine just below the seat fastener in back. Velcro it to the rear fender. It just fits under there when you put the seat on. It really can't go anywhere.

Jlk_250 is spot on about the correct wire to tap into.:thumbup:
 

·
Registered
Joined
·
546 Posts
It's weird. Some of them apparently just need the key on, some need the engine running. I had a PCIII on my '08 and with the external 9V battery I just needed the key to be on. Now I have a PCV and the engine has to be running before I get a TPS reading. But other people have reported that they just need the ignition on with their PCVs. I asked DJ and they said the bike needs to be running, but I was talking to their third string guy who didn't know the details. Makes it a little hard to calibrate the TPS at full throttle.
 

·
Registered
Joined
·
5 Posts
and my 2010 just needs the ignition to be on:headscrat
Sorry to bring up an old thread but I tapped into the third wire from the end as stated in the thread but am not getting any TPS setting to display on my laptop and am getting an error message when trying to retrieve or load a map. Any suggestions? I am at my wits end with this bike running like crap all the time...its a 2009 smr510 just like the thread title. Anyone have a picture of the specific wire im supposed to be tapped into?
 
1 - 11 of 11 Posts
Top