SuperMoto Junkie banner
1 - 7 of 7 Posts

·
Registered
Joined
·
65 Posts
Discussion Starter · #1 ·
Just got the engine back in new piston (wossner) gaskets started up no bother apart from alot of smoke from the exhaust i thought it was just the oil burning of as it went after it warmed up.Now i have fired it up again its done the same but then i noticed oil coming out of the left hand exhaust header pipe.
any ideas will be welcome as im now sick as ****
thanks
 

·
Registered
Joined
·
961 Posts
Call whoever did the work and let them know what's happening.

It's tough to diagnose your exact problem over the net, I have my suspicions, but you need to talk to your mechanic ASAP!
 

·
Registered
Joined
·
65 Posts
Discussion Starter · #5 ·
unfortunately i did the work myself ive just had it running for about 20 mins there was a little smoke on start up but not as much as before but there is still a small amount of oil leaking from the header
 

·
Registered
Joined
·
961 Posts
unfortunately i did the work myself ive just had it running for about 20 mins there was a little smoke on start up but not as much as before but there is still a small amount of oil leaking from the header
Just wondering why you replaced the piston (and rings?) at 2000 miles?

Did you use the service manual to do the work?
 

·
Registered
Joined
·
65 Posts
Discussion Starter · #7 ·
destroyed fourth gear so decided while it was open id replace the piston save doing it later.
Followed the manual to the letter but its the first time ive done a four stroke so didnt know wether this was the norm till the rings seated properly
 
1 - 7 of 7 Posts
Top