SuperMoto Junkie banner

261 - 280 of 282 Posts

·
Registered
Joined
·
689 Posts
Unless you buy gas from someone with very dirty tanks, you will be fine with the filter

I have cleaned injectors in 3 different bikes, all had the same result, MUCH BETTER at part throttle, just when you start opening the throttle and you had this jerk before, after it was gone, and a little bit better up top

All 3 showed no problems in spray pattern before cleaning

But being so new, I'm not sure you will see a difference by cleaning the injector, but it doesn't hurt to do it

Proper injector cleaning: At a shop, that they sink it in a ultrasonic bath, with special chemical, while at the same time operating it, and they have a test bench to see volume and spray pattern, response at different rpm, and leakage

I have read some other ridiculous tactics like using a 9v battery and carb cleaner, carb cleaner is not going to descale the insides of the injector, so do it properly at a shop, it only costs $5-$10 for me, and I know 100% that the injector is good and checked
 

·
Registered
Joined
·
106 Posts
I think it has no back pressure. Might be a map issue with the air box open and the exhaust... I'm debating buying the evo 1 air box lid see if it helps. Going to the gap next week and don't need any surprises :)
 

·
Registered
Joined
·
2 Posts
Im gonna try modified 132 map for smc 2009 by taijohnsen. I have akra exhaust and kn open pod filter ru-0830. I also disabled SAI and O2 in his map.







EP.hex file
 

·
Registered
Joined
·
2 Posts
Should I adjust Throttle Position Sensor? Tuneecu shows

Throttle grip sensor should be within specs.I have 2009 smc


690 (08-10)
Throttle Pos Sensor, closed 0.5-0.54, open 0.70-0.74 THAD.
Throttle grip sensor closed 0.70-0.74v APAD

What is the 3,3 value under the Throttle? Thanks
 

·
Registered
Joined
·
1,632 Posts
So I've been running TaiJohnson's map for over a year with great resualts or so I thought. The plug was always white. Finally got my 690 on the dyno and this map is REDICULOUSLY LEAN everywhere. It wouldn't even read on the AFR meter at first. After quite a bit of finagling we got it down to safe levels. This is running evo 2 airfilter/no airbox, and akra slip on. My 690 SMC put down 65HP and it was 95 degrees with near 100% humidity about 1000ft ASL. However if your running TaiJohnson's map...Replace it Immediately with my much richer map. Here's a Link to the map in my dropbox. It is only the FI map. Nothing has changed with the EP map. Its in the dropbox folder for you to use also if you need it. https://www.dropbox.com/sh/mnxuc8nuufz3s4r/AAD5XlFvlLr0AqU_2z_SLO22a?dl=0
 

·
Registered
Joined
·
1,632 Posts

·
Registered
Joined
·
1,632 Posts
what about the throttle map?
Nothing has changed with the EP map. I uploaded that to a drop box folder for everyone to use also. Its just Taijohnson's EP map.
 

·
Registered
Joined
·
684 Posts
Do you know what condition your injector or fuel filter are in?

I had my injector cleaned at around (only) 4500 miles. The report that came back with it noted a very restricted flow before cleaning.

I replaced the fuel filter around the same time and found it to be very very dirty.

A number of folks have noted needing to replace filters and clean injectors very early on these bikes

If you've never cleaned the injector you might be chasing the wrong issue with that richer map. Just my $0.02
 

·
Registered
Joined
·
1,632 Posts
Do you know what condition your injector or fuel filter are in?

I had my injector cleaned at around (only) 4500 miles. The report that came back with it noted a very restricted flow before cleaning.

I replaced the fuel filter around the same time and found it to be very very dirty.

A number of folks have noted needing to replace filters and clean injectors very early on these bikes

If you've never cleaned the injector you might be chasing the wrong issue with that richer map. Just my $0.02
Injector and fuel filter have been cleaned/ replaced within 1k miles.
 

·
Registered
Joined
·
215 Posts
B Palmer22,

What differences in driveability do you notice with your richer map loaded?

Cheers,
Roy
 

·
Registered
Joined
·
1 Posts
Thanks to all the contributors of this thread. I loaded up Tai's maps today, and the bike is transformed. Saved me from purchasing a vortex.

:clap:
 

·
Registered
Joined
·
5 Posts
Hey!

I recently installed an evo 2 camshaft on my -08 690. It's having issues while idling, and easily stalls. Furthermore, when I whack the gas on gear, the engine stalls and as soon as I release it the engine comes back to life. If I give it gas smoothly, it accelerates without issues. What sort of maps are you running on your evo 2's?
 

·
Registered
Joined
·
97 Posts
On my 12 smc r with evo 2 I am running a modified evo 2 map, with more fuel and some changes in other parameters. Works very good. Had some problem with running the stock evo 2 map.

What kind of map are you running? Are you familiar with tune ecu?
 

·
Registered
Joined
·
5 Posts
Yup I am familiar with TuneECU. I'm running stock evo 2 maps. When I first fired her up, she idled nicely for 10 minutes, and then the stalling issues began. I've tried flashing the maps again to the ECU with no success.

I tried to adjust my TPS as well. How is the throttle position sensor (THAD) supposed to behave when disconnected and connected? When I have the motor drive connector unplugged and adjust the TPS to its nominal values (0.5v-0.54v closed and 0.7-0.74v open) and then connect the motor drive connector again, the upper voltages drop by 0.02v. Is the TPS value supposed to drop when the motor drive is connected again?
 

·
Registered
Joined
·
97 Posts
All right. Yes the voltage will change when connecting the connector again. Voltages has to be checked with connector disconnected. Do not bother what the voltages are when the connector is connected again.

Are you using the SAS system and O2 lamda sensor? Disconnecting those and disable them in tune ecu makes the engine run smoother.

On my custom evo 2 map i disable both SAS system and O2 lamda sensor, removed the sensor and put a M12x1.25 bolt in the open hole. Used an Innovate wideband lamda sensor and ended up with giving 10% more fuel across the whole rpm band in both F and L maps. Fuel usage is around 0,5-0,6 liter per 10 km. The air fuel ratio is around 12,8 to 13,2 under all throttle scenarios.

I also changed the FL switch to 10-10-0-0-0-0-0-0. I did not adjust the ignition curves.

On the throttle table i adjusted all parameters to 100 on the performance map.

All this adjustment can you read about earlier in this post, on the first page.

With this setup in the mapping my bike runs very good, no issues at all.

The only thing is that the bike is very sensitive to throttle input when the engine is cold. I always let it idle until tree bars on the temperature indicator before driving. Taking off earlier than that it may stall and stop.
 

·
Registered
Joined
·
5 Posts
Thanks! Yes, the SAS system and O2 lambda sensor is disconnected and disables (unchecked).

I'll double check the TPS on tuesday, and upload a map with your tips and report back with the results then! :thumbup:
 

·
Registered
Joined
·
4 Posts
Hello,

I've installed these maps.
But my engine doesn't want to lower rpm in gear under 4k Rpm.
So no engine braking.

Did anybody else experience this and knows hos to solve it?

Thanks in advance
 

·
Registered
Joined
·
4 Posts
So I've been running TaiJohnson's map for over a year with great resualts or so I thought. The plug was always white. Finally got my 690 on the dyno and this map is REDICULOUSLY LEAN everywhere. It wouldn't even read on the AFR meter at first. After quite a bit of finagling we got it down to safe levels. This is running evo 2 airfilter/no airbox, and akra slip on. My 690 SMC put down 65HP and it was 95 degrees with near 100% humidity about 1000ft ASL. However if your running TaiJohnson's map...Replace it Immediately with my much richer map. Here's a Link to the map in my dropbox. It is only the FI map. Nothing has changed with the EP map. Its in the dropbox folder for you to use also if you need it. https://www.dropbox.com/sh/mnxuc8nuufz3s4r/AAD5XlFvlLr0AqU_2z_SLO22a?dl=0
Did you have any trouble with high idle in gear?
If so did you solve it? And how?
 

·
Registered
Joined
·
3 Posts
Hi,

I have a KTM 640 vDuke II from 2004, with an Ignitech programmable CDI. This bike has a Keihin FCR carb, akrapovic, cone filter...and I am trying to create an ignition map, with TPS, to program the CDI. Would it be feaseble to use an I1 ignition map from those available for the KTM 690? In the 640 repair manual it says that maximum ignition advance is 38 BTDC at 6000rpm, but no extra info.....

Thanks a lot

link to map
 
261 - 280 of 282 Posts
Top