SuperMoto Junkie banner

41 - 60 of 83 Posts

·
Registered
Joined
·
1,159 Posts
Discussion Starter #41
Xmoto 5,000 miles. Installed a new Leo Vince slip on. After that the bike refuses to idle correctly and stalls at every light. Also when I'm circulating in lower gears at low speed it stalls sometimes. Are any of you guys aware of any specific adjustment I should make to my bike to avoid this situation. I love the sound and quality of the Leo Vince exhaust but the stalling is becoming annoying. This does not happen with the stock setup :hmmm:
For what it's worth, I never experienced that when I put my leo vince slip on. Probably just needs the idle adjusted.
 

·
Registered
Joined
·
92 Posts
Hello guys I had the water pump problem too.
The o'rings were dead...
I did the reparations my self but it was boring to do... need to remove the rear arm of the wheel (don't know how to say that in english, sorry) ^_^
 

·
Registered
Joined
·
1,159 Posts
Discussion Starter #44
Hello guys I had the water pump problem too.
The o'rings were dead...
I did the reparations my self but it was boring to do... need to remove the rear arm of the wheel (don't know how to say that in english, sorry) ^_^
are you saying you removed the swing arm to replace the water pump seal? because the water pump cover is on the front corner of the engine, and the service manual doesn't mention swing arm removal in the process.
 

·
Registered
Joined
·
92 Posts
are you saying you removed the swing arm to replace the water pump seal? because the water pump cover is on the front corner of the engine, and the service manual doesn't mention swing arm removal in the process.
I had to remove all the left side because I changed the gasket.
I explain me : The water pump and the clutch cover are screwed on a bigger part... I change this gasket too and two screw are hidden behind the swing arm. That's why I had to remove the swing arm.

Can you scan and put on the forum the pages were they talk about on the service manual please ?:lol: I'ts curious what you're telling me...
 

·
Registered
Joined
·
1,159 Posts
Discussion Starter #46 (Edited)
I had to remove all the left side because I changed the gasket.
I explain me : The water pump and the clutch cover are screwed on a bigger part... I change this gasket too and two screw are hidden behind the swing arm. That's why I had to remove the swing arm.

Can you scan and put on the forum the pages were they talk about on the service manual please ?:lol: I'ts curious what you're telling me...
You know what, you're right, you DO have to remove the swing arm. I apologize for the misinformation, I was looking at the wrong procedure. Here is the procedure for the USA model xmoto.

CLICK THUMBNAILS FOR FULL SIZE IMAGE

 

·
Registered
Joined
·
92 Posts
You know what, you're right, you DO have to remove the swing arm. I apologize for the misinformation, I was looking at the wrong procedure. Here is the procedure for the USA model xmoto.

CLICK THUMBNAILS FOR FULL SIZE IMAGE

Thanks for the pics it's very gentle.
I can see the mistakes I did. ^^ lol
Can you correct me when my english's not good please ?
It helps me a lot because I did't practice it for a while. Lol
 

·
Registered
Joined
·
39 Posts
Having left blinker issues, anytime i jump on the throttle real hard the blinker turns on, sometimes it'll stay on for a minute or two sometimes its just 3 quick flashes then turns off? :hmmm: i dont know what to do, any suggestions?
 

·
Registered
Joined
·
1,159 Posts
Discussion Starter #49
Having left blinker issues, anytime i jump on the throttle real hard the blinker turns on, sometimes it'll stay on for a minute or two sometimes its just 3 quick flashes then turns off? :hmmm: i dont know what to do, any suggestions?
that's weird, have you checked all your grounds?
 

·
Registered
Joined
·
5,434 Posts
Warranty out on mine and I have around 10,000 on the bike. I had to replace the fork seals 4 times, and reset the computer 4-5 times (kept stalling when cold). That was over a year ago and not problems to date. I ride my bike 99% of the time off road but hit the track once this year as well as ride on the street. Here are some pics of my ride. I have since added a set of Woody's off road wheels as well :clap: No plan on selling mine anytime soon. I think it is a great all around bike. BMW mechanics told me that the motors will run FOREVER..... and not to worry about checking the valves until 20K





 

·
Registered
Joined
·
92 Posts
P
Warranty out on mine and I have around 10,000 on the bike. I had to replace the fork seals 4 times, and reset the computer 4-5 times (kept stalling when cold). That was over a year ago and not problems to date. I ride my bike 99% of the time off road but hit the track once this year as well as ride on the street. Here are some pics of my ride. I have since added a set of Woody's off road wheels as well :clap: No plan on selling mine anytime soon. I think it is a great all around bike. BMW mechanics told me that the motors will run FOREVER..... and not to worry about checking the valves until 20K





Hi Jolly. What's that exhaust that you have on your bike ? Home made ?
 

·
Registered
Joined
·
5,434 Posts
It is a white brothers from a RMZ450, I bought it new for $149 off of ebay. A friend of mine fabricated a mid pipe. It sounds and works great. I def. noticed a difference and luckily it is not much louder than the stock pipe with the spark arrestor, without it WOW.... It is LOUD! I have his contact info if anyone is interested. He does great work and owns the X Chall so he can use that to "test" the fit.





P

Hi Jolly. What's that exhaust that you have on your bike ? Home made ?
 

·
Registered
Joined
·
92 Posts
It is a white brothers from a RMZ450, I bought it new for $149 off of ebay. A friend of mine fabricated a mid pipe. It sounds and works great. I def. noticed a difference and luckily it is not much louder than the stock pipe with the spark arrestor, without it WOW.... It is LOUD! I have his contact info if anyone is interested. He does great work and owns the X Chall so he can use that to "test" the fit.


Okay nice work. Last year I did the same I took a Silencer from a CRF 450, a SHARK (italian brand :rolleyes:) and I did this, but I mounted it maybe 3 times, it's too loud, it's a big heavy sound you know. Every time I put it on my bike, cops arrest me . :lol:

SOME PICS.






 

·
Registered
Joined
·
5,434 Posts
It looks good, mine was CRAZY loud without the spark arrestor, it was almost unrideable. I added the spark arrestor and now it is just a touch louder than stock. Does Shark have spark arrestors? It might help out.

Okay nice work. Last year I did the same I took a Silencer from a CRF 450, a SHARK (italian brand :rolleyes:) and I did this, but I mounted it maybe 3 times, it's too loud, it's a big heavy sound you know. Every time I put it on my bike, cops arrest me . :lol:

SOME PICS.
 

·
Registered
Joined
·
92 Posts
It looks good, mine was CRAZY loud without the spark arrestor, it was almost unrideable. I added the spark arrestor and now it is just a touch louder than stock. Does Shark have spark arrestors? It might help out.
Hey !

Scuse me for the late answer. No it doesn't have a spark arrestor at origin... And all the DB killer I made just, break and fall into. :lol:
 

·
Registered
Joined
·
1,159 Posts
Discussion Starter #56
Alright QUIRK, how many miles are you up to now? I'm sure you've passed me by now. I bought a brand new er6, and I've been riding that quite a bit more than the bmw...

Also, did your fuel sensor turn out to be bad??

:thumbup:
 

·
Registered
Joined
·
552 Posts
Well i would be riding all year like usual but the snow here in CT is crazy this winter. I don't know the exact number but its between 13k and 14k. Last time i rode was for a quick new years day ride, on which i hit a patch of snow and dropped it, nothing bad just a broken peg and scuffed hand gaurd.

What are you up to now? I have to check mine cause i'm supposed to listen to my engine for rossi but i forgot to last night cause i was shoveling snow.
 

·
Registered
Joined
·
552 Posts
Oh and i still haven't been to the dealer to check the fuel sensor or have the recall done so I'm not sure if its bad or not. I have been too afraid it won't work so i top it off every ride.
 

·
Registered
Joined
·
1,159 Posts
Discussion Starter #59
Well i would be riding all year like usual but the snow here in CT is crazy this winter. I don't know the exact number but its between 13k and 14k. Last time i rode was for a quick new years day ride, on which i hit a patch of snow and dropped it, nothing bad just a broken peg and scuffed hand gaurd.

What are you up to now? I have to check mine cause i'm supposed to listen to my engine for rossi but i forgot to last night cause i was shoveling snow.
ooooh yeaah, snow.. Sorry, I live in Texas, I forgot all about snow, and winter :lol: I was actually going to start mine up last night and try to listen for a tick as well, but I've been working like a crazy, and haven't been getting home till late, and normally will eat a late dinner and jump straight into bed... Trying to bust ass and make some dough, planning a few weeks in Europe this year :thumbup:

Yeah saw your post about looking for pegs, I might be trying some sport bike pegs soon, nothing wrong with mine just kind of curious to try something else out.
 
41 - 60 of 83 Posts
Top