SuperMoto Junkie banner

1 - 9 of 9 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter · #1 ·
Installed the 320mm Rotor that was included in the sportsman kit along with new EBC race pads and I'm getting a pulsing feel as i grab the the lever. happens at any amount of pressure or "Grab"..

on a side note, I didnt install the included front stainless brake line as i didnt have a bleeder or fluid on hand to complete the change. I'm assuming that maybe the rotor was not installed correctly or torqued propertly?
 

·
Premium Member
Joined
·
4,683 Posts

·
Registered
Joined
·
530 Posts
wear them in, and then see.. also, a huge heads up dont over fill your master with dot4 it will expand in the heat and lock up your front brake if you put to much in..
 

·
Registered
Joined
·
54 Posts
Discussion Starter · #6 ·
:Funny:

Going up the Snake today.. been noticing its fading away and gripping even harder with less pressure. gonna LOVE this!
 

·
Registered
Joined
·
54 Posts
Discussion Starter · #7 ·
update...

after some good runs up and a lowside.. they are are now starting to pulse alittle harder when i'm at any speed. Thinking that i'll put on the stock pads back on and see if it helps but i'm thinking my rotor is tweeked?

I dont see how fluid or the brake line could be the issue.....

on a side note, I need to air the pressure down from 30's to about 20ish... I think that was the culprit of running out of grip on that lowside as I havn't used up quite the whole tire.
 

·
Registered
Joined
·
530 Posts
does your lever pull ever fell tight? like it could be super stiff.. then go to stock feeling
 

·
Registered
Joined
·
54 Posts
Discussion Starter · #9 ·
no, it doesnt feel tight.. it's stock plushy feeling but with better bite.
 
1 - 9 of 9 Posts
Top