SuperMoto Junkie banner

1 - 20 of 22 Posts

·
Registered
Joined
·
50 Posts
Discussion Starter #1
has any body's gas light stop working on there 610
i don't have my manual yet to look at the wiring
 

·
Registered
Joined
·
1,243 Posts
Check the fuel valve on the left side of the tank. I think it needs to be opened for the light to work. There are also wires on the right side of tank by the main fuel petcock, see if they've been damaged.
 

·
Registered
Joined
·
5,649 Posts
My wire connection at the petcock finally broke loose from all the repeated tank removals for rejetting. I bet I've had the tank off that bike 100 times. We'll see if I miss having the light or not. :hmmm:
 

·
Registered
Joined
·
50 Posts
Discussion Starter #11
i will look around on it. i know the light come on when the key is turned on but sensor is not working because i was left on the side of the road
THANKS for all the input
 

·
Registered
Joined
·
1,243 Posts
I think that petcock on the left needs to stay open for the fuel light to work. Check the manual, I could have that wrong?
 

·
Registered
Joined
·
5,649 Posts
Not the case (at least on my '06), the fuel sensor is wired to the right side petcock only. That way you have a sort of redundant system with a warning light and a reserve. I've always kept the reserve petcock closed, relied on the warning light and occasionally had to resort to the reserve when too far from a fill-up.
 

·
Registered
Joined
·
363 Posts
Not the case (at least on my '06), the fuel sensor is wired to the right side petcock only. That way you have a sort of redundant system with a warning light and a reserve. I've always kept the reserve petcock closed, relied on the warning light and occasionally had to resort to the reserve when too far from a fill-up.
+1, That is how I run.
 
1 - 20 of 22 Posts
Top