SuperMoto Junkie banner

1 - 16 of 16 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
ok i have a 07 drz400sm full yosh 3x3 and jet kit for whatever reason when im on the highway 50-65mph maintaning a constant speed my drz feels like its starving for fuel and jerks me around, but when i give it gas it accelerates just fine. it only does it when im at higher speeds trying to maintain a constant speed. at first i thought it was a vacume leak or somthing so ran it with the petcock in on mode and it still does it. please help
 

·
Registered
Joined
·
3,055 Posts
it could be some crud that is in the fuel delivery circuit --
petcock - fuel line - float valve -

You could try this and see if it helps before removing carb ect-
drain float bowl - remove fuel line from petcock -
blow compressed air threw float bowl drain hose -- (dont use real high pressure air)
see if any crud comes out of fuel line-
ride bike and see if any difference --
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
thanks that sounds easy enough, ill give it a try and repost the results
 

·
Registered
Joined
·
530 Posts
sounds like you are right at the point where your pilot jet is opening.. its not starving for fuel but getting over loaded with fuel.. only happens at that speed.. try pulling a large incline at that speed and see if it still does that.

my friend had this problem with dyno jet, jet kits
 

·
Registered
Joined
·
37 Posts
Agreed! Dyno Jet kit is the shits. JD kit solved the same problem and then I solved the Mikuni carb prob and got a FCR. upgradeitis...Definitely a jetting issue.
 

·
Registered
Joined
·
81 Posts
I had a similar problem with my 230. It was shuddering on the bottom and bogging 1000 rpms before redline. Went 35 to a 40 pilot, and 140 to135 main. Fixed it right away.
 

·
Registered
Joined
·
1,386 Posts
A bone stock drz400sm its doing it. ,,,,,I install a slip on, 3x3 mod. 25 pilot . 155 main jet. And still doing it,,,,,,,,WTF. Thanks in advance
shim the needle. if you ride it lean like that for long, you'll kill the rings.

check your stator to ensure its not that, since you've changed jetting.
 

·
Registered
Joined
·
61 Posts
I am having the same issue at higher speeds when cruising around 70 to 80 anyone have any results to what really helped or fixed the issue.
Thanks
Tyler
 

·
Registered
Joined
·
61 Posts
Yeah i plan to call JD and talk to them about maybe redoing my jetting at a different setting for the elevation i live. I can go from 800ft to 6000ft within miles from each other.
 

·
Registered
Joined
·
27 Posts
Yeah i plan to call JD and talk to them about maybe redoing my jetting at a different setting for the elevation i live. I can go from 800ft to 6000ft within miles from each other.
I don't think it's the jetting though
when was bone stock was king the same thing
now slip on 3x3 mod main jet 155, oversize pilot jet. Shim needle.
And. Still or the same. Fd%*# thing :)
 
1 - 16 of 16 Posts
Top