SuperMoto Junkie banner
1 - 20 of 35 Posts

·
Registered
Joined
·
271 Posts
Discussion Starter · #1 ·
I love my smc , but here are some problems i'm having with it that i havent seen anywere else on this site.

-when shifting from 4 to 5 it sometimes goes into neutral.

-my instrument panel got moisture in it and it fogs up (& no i never used a pressure washer when cleaning it).

-on hot days the fuel in the tank gets so hot it starts to perculate and the bike stalls at low speeds.

Fellow 690 smc owners please let me know if you have had the same problems.
 

·
Registered
Joined
·
38 Posts
I got the neutral from 5 to 6 if i didn't shift hard but that has stopped since the first oil change.

ya my instrument panel is messed up too. Mine isn't moisture but more like dust. My dealer said it has happened to a smr they sold this year too. They are going to replace it when i bring it in to re-map for the LeoVince that should be in next week. If it keeps dusting up i am going to get them to replace it with a vapor panel or something like it before the warranty is up.

Mine has stalled a few time, really haven't checked the temp of the gas but i did notice that it runs a little more erratic when the fuel is low. I saw on another thread that someone attributed that to a weak fuel pump. And the problem was fixed after replacing it. I am going to get my dealer to check that out next time i am in.


Most of these things have been discussed in previous threads so take a read through them.
 

·
Premium Member
Joined
·
6,598 Posts
1) put more effort into your shifts, if you're using the clutch to shift up: don't bother with it, learn to shift without clutching, seems in some cases this actually helps the false neutral problem some people tend to get.
2) that's a warranty issue, if you take the bike to your dealer they'll replace the panel for free. there's allready a couple members on here that have had to do that if I recall correctly.
3)don't have an answer for that one
 

·
Registered
Joined
·
102 Posts
Funny you should ask about the gauges.....

Last week I started getting some kind of dust particles inside the gauge panel and today it has two small "fogged up" dots.......sucks. It's never seen a hose, pressure washer, or a drop of rain.

I love this bike, but I miss the quality of my Honda CBR.

JOHN
 

·
Registered
Joined
·
120 Posts
all common problems. my guage is fogged. false neutral goes away after a while. i put an FMF pipe on mine a few days after the bike came out, so heat was not a problem.
 

·
Registered
Joined
·
310 Posts
i too have the guage problem, it's plastic powder from the internals rubbing together. i already pulled it apart once and cleaned it out and now its back again. i want to put some more miles on the bike before i get the dealer to replace the guage cluster. i have also had the false neutral problem but i has for the most part gone away. i noticed that the breather hose for my gas tank was routed so that one of the pads for the seat was sitting on it, so i couldn't breath right so i zip tied it out of the way and it hasent stalled since.
 

·
Registered
Joined
·
546 Posts
i too have the guage problem, it's plastic powder from the internals rubbing together. i already pulled it apart once and cleaned it out and now its back again. i want to put some more miles on the bike before i get the dealer to replace the guage cluster. i have also had the false neutral problem but i has for the most part gone away. i noticed that the breather hose for my gas tank was routed so that one of the pads for the seat was sitting on it, so i couldn't breath right so i zip tied it out of the way and it hasent stalled since.
How hard is it to take apart the gauge thing to clean that? I've had the dust for a while, and I can't read my mileage, but haven't gotten around to taking it apart to clean it. And the dealer I bought the bike from is 2hrs away (though I'm sure there is another KTM dealer closer, but not sure if they will "service" this bike, since none of them sell/sold it).
 

·
Registered
Joined
·
310 Posts
i thought it was pretty easy 4 bolts and 3 screws i think.and one plug. just be careful when u open up the gauge.
 

·
Registered
Joined
·
599 Posts
I parked my smc on the bed of my truck for about 4 hours on a 100F+ day. I think the panel got too hot and the corner where the time (clock) displays is clouded up. I don't think it's condensation because it's always there.
 

·
Registered
Joined
·
569 Posts
i only have the junk in the pod display, no problems with any of the other things you listed
 

·
Registered
Joined
·
271 Posts
Discussion Starter · #12 ·
i took apart my speedo & wiped the shi+ off fo it , its not hard to do.
also i took it to the dealer for the stalling , i live in canada and apparently theres only 4 or 5 of em in the whole country. so the techs had never even seen a 690 smc , so they just sent an email to ktm about the problem. maybe ktm will send me a nice pipe so the tank dont get so hot.:rolleyes:
 

·
Registered
Joined
·
304 Posts
Go read the "joys of FI" thread in dualsporter section of ktmtalk,,,,IIRC over 20 various 2007-08 690s are suffering from the stalling and a few have had fuel pumps fail, two fuel tanks started melting on front tank SM690s...One bike has been bought back by KTM who couldn't fix it.
 

·
Registered
Joined
·
189 Posts
i took apart my speedo & wiped the shi+ off fo it , its not hard to do.
also i took it to the dealer for the stalling , i live in canada and apparently theres only 4 or 5 of em in the whole country. so the techs had never even seen a 690 smc , so they just sent an email to ktm about the problem. maybe ktm will send me a nice pipe so the tank dont get so hot.:rolleyes:
Good luck with that....:laughingr
 

·
Premium Member
Joined
·
6,598 Posts
Go read the "joys of FI" thread in dualsporter section of ktmtalk,,,,IIRC over 20 various 2007-08 690s are suffering from the stalling and a few have had fuel pumps fail, two fuel tanks started melting on front tank SM690s...One bike has been bought back by KTM who couldn't fix it.
the stalling issue is one thing but I never saw any pictures of the melted tank and when owners that claimed to have experienced this problem were asked about it they didn't go into further.

I'm trying to find info on the random stalling but so far I haven't been able to find any 690 owners that have had to deal with this, seriously I've talked to over 20 owners and 2 mecanices and came up with nothing, and with nothing I mean no-one even knew about this problem because they didn't encounter it yet.
 

·
Registered
Joined
·
2,638 Posts
the stalling issue is one thing but I never saw any pictures of the melted tank and when owners that claimed to have experienced this problem were asked about it they didn't go into further.

I'm trying to find info on the random stalling but so far I haven't been able to find any 690 owners that have had to deal with this, seriously I've talked to over 20 owners and 2 mecanices and came up with nothing, and with nothing I mean no-one even knew about this problem because they didn't encounter it yet.
Skully I have a stalling issue. It isn't consistent at all, has happened 15 or so times since I've owned the bike, 2,200 miles now. It can go a week or more with out happening. It always happens coming to a stop with the clutch engaged. I can live with it but I hope eventually KTM gets it figured out.
 

·
Premium Member
Joined
·
6,598 Posts
Skully I have a stalling issue. It isn't consistent at all, has happened 15 or so times since I've owned the bike, 2,200 miles now. It can go a week or more with out happening. It always happens coming to a stop with the clutch engaged. I can live with it but I hope eventually KTM gets it figured out.
well that does explain a lot if the issue really is that random.
 

·
Registered
Joined
·
2,638 Posts
well that does explain a lot if the issue really is that random.
It's so random that I haven't done anything about it. If I bring it to the dealer the chances it will happen while they ride it are slim to none, then I'd be bikeless for who knows how long. I'm just waiting and with time hoping that KTM gets it sorted and have a recall to correct the problem.
 

·
Registered
Joined
·
304 Posts
Check out the nearly destroyed 690e on advrider, IIRC page 263 in the 690 adv merged thread. Guy jump started a dead battery and the cat over heated, lighting the plastics, side panel & rear mounted fuel tank on fire. Lucky nobody was killed. The pics speak for themselves.

That ktmtalk thread outted over 20 bikes with intermittant stalling, 07s, 08s, SMC, E, Duke and SMRs.
 

·
Registered
Joined
·
46 Posts
LCD fogging

My SMC has 1200 miles on it and doesnt have a stalling problem however
last night I noticed what looked like fogging in the upper and lower left
corners and along the bottom of the LCD panel. Encouraged by what I
read here I took it apart. 5 screws to get the instrument off the bike and
4 to open it up. It actually looks some some assembly glue has oozed
out (summer heat Im guessing) of the LCD sandwich and smeared on the
covering plastic. I was able to clean it off with a Q-tip and some glass
cleaner. Easy does it though. Total job took me only 30 minutes.

$.02
 
1 - 20 of 35 Posts
Top