SuperMoto Junkie banner

1 - 5 of 5 Posts

·
Registered
Joined
·
452 Posts
Discussion Starter #1
I recently changed my front countershaft sprocket from 16 to 17. Now when I went to ride the bike- as soon as it goes in gear, it cuts the engine off. I don't see a switch down on the shifter or counter sprocket area. What is screwing up? Or is it my clutch lever switch?
 

·
Registered
Joined
·
72 Posts
It's got to be your clutch switch, the bike thinks the clutch is engage and is shutting off to stop you from launching...

Check those connections. I've had those wiggle out on my Suzuki in years past.
 

·
Registered
Joined
·
452 Posts
Discussion Starter #3
Finally fixed it. Turns out there's a magnet on the kickstand that gets misaligned if you have the bike on a lift. Would have been a 30 second fix, but too bad I did a little more trouble shooting like removing the clutch lever, testing the clutch switch, removing the kick stand sensor, cutting the wires to bypass the switch, finding out the canbus won't let you do that :damn:, soldering the harness back together, using a fridge magnet to verify the switch works, then finding the magnet out of place. :clap:
 

·
Registered
Joined
·
600 Posts
Finally fixed it. Turns out there's a magnet on the kickstand that gets misaligned if you have the bike on a lift. Would have been a 30 second fix, but too bad I did a little more trouble shooting like removing the clutch lever, testing the clutch switch, removing the kick stand sensor, cutting the wires to bypass the switch, finding out the canbus won't let you do that :damn:, soldering the harness back together, using a fridge magnet to verify the switch works, then finding the magnet out of place. :clap:
So, this is a magnetic safety switch for the "kickstand? Never knew.
Jeff
 
1 - 5 of 5 Posts
Top