SuperMoto Junkie banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Bike has sat for couple years without starting. Ran fine before. Now won't start. Drained fuel. Cleaned fuel filter. Pulled carb down and cleaned/checked everything. Jets are not blocked. Put new plug and looked inside where plug goes and I can see rust on the exhaust valve so I'm thinking maybe stuck valve?? Can someone link me to procedure for replacing valves and does this mean I may as well do top end rebuild. Any help appreciated
 

·
Registered
Joined
·
41 Posts
Was this your bike when it ran fine before, or is it new to you and the previous owner says it ran well?

I don't know much about that model, but I'd pop the valve cover off and make sure all the valves move when the camshaft rotates.
 

·
Registered
Joined
·
1,844 Posts
Can someone link me to procedure for replacing valves and does this mean I may as well do top end rebuild. Any help appreciated
Are these help any
Engine teardown pic
http://supermotojunkie.com/showthread.php?126359-Engine-complete-tear-down-step-by-step-with-pics

Here is engine built-up
http://supermotojunkie.com/showthread.php?130347-Huskvarna-complete-rebuild-pic-by-pic-(assembly)


And here is service, it is very slow to download that page
http://docs.wavenetworks.us/manuals//2005%20ALL%20250-450-510%20Repair.pdf
 

·
Registered
Joined
·
444 Posts
I always like to run my bikes after washing them. Sometimes you can get little water in the exhaust or head pipe after washing which can cause some corrosion or rust on the exhaust valves. Good luck with the new parts!
 
1 - 6 of 6 Posts
Top